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What’s New in Netfabb 2018

Automation, parametric supports, & interoperability

New latticing toolkit and improved topology optimization

Export compensated shape, stress results & more control

Dynamically edit Superstructures and Flexistock

Maximize Machine Efficiency
Netfabb

Part orientation module & support preview
Netfabb Standard

What is it?

The ‘Orient Part’ features analyzes parts,
displays a preview of support structures,
and provides suggestions with regard to:
Supported area & volume
Outbox volume
Part height
Why use it?

Minimize supports, reduce finishing effort,
and reduce the learning curve for new
operators.
How to use it?

Open Arrange > Orient Part from the main
menu.

Pins & holes while cutting
Netfabb Standard

What is it?

The ‘Automatic Pin Creation’ function
generates cylinder or hook pins and holes
when splitting parts.
Why use it?

Easier reassembly process with proper
alignment between parts.
How to use it?

In the ‘Cut’ panel, select ‘Automatic Pin
Creation’.
Open Pin Settings dialog to customize pin
type, sizing, and spacing.

UX refinements
Netfabb Standard

What is it?

Restructured main menu and context menu
along with more clearly named categories.
Why use it?

Easer to find the command you need, when
you need it.
How to use it?

Use the main menu or open the context menu.

Parametric support structures
Netfabb Premium

What is it?

Support definitions are stored so supports
can be automatically updated due to
changes to orientation, assembly, or
geometry.
Why use it?

Eliminate rework time deleting and
redefining support structures.
How to use it?

In the Prepare>Support menu, select
‘Recalculate Attached Support.’

Parallel support creation
Netfabb Premium

What is it?

Assign different, custom support strategies to parts
or sets of parts and use a queue to track progress.
Why use it?

Background calculation of supports allows for faster
support creation for multiple parts that require
unique approaches.
How to use it?

View job manager to monitor support creation
progress.

Angled supports
Netfabb Premium

What is it?

Angled supports project outside the part to
the print platform.
Why use it?

Reduce the cost and time required for postprinting finishing efforts by avoiding part-topart support structures.
How to use it?

Select ‘Angled block support’ from the support
creation dialog.

Faster 3D packing
Netfabb Premium

What is it?

A new multi-level penetrating algorithm for the
Monte Carlo packer.
Why use it?

Reduce 3D packing time for certain configurations
by as much as 30-50% compared to previous
versions.
How to use it?

No change, algorithm improvements are
implemented in the existing 3D Packing
capability.

Extended automation
Netfabb Ultimate
Example script workflow:

What is it?

LUA scripting is an development environment
for automating Netfabb functionality.
Example scripts have now been added for
common workflows.
Why use it?

Prepare builds faster by automating tasks
that are repetitive or common across projects.
How to use it?

Example scripts are in the Netfabb
installation folder under Examples\Lua
Scripts.
LUA Scripting Reference

Import &
tessellate

Check wall
thickness

Save into
pass/fail folders

Import valid
files

Automatic 3D
packing

Advanced Toolpath Utility
Netfabb Ultimate

What is it?

A JavaScript development environment for
material developers, machine manufacturers,
and expert AM users to create toolpath
parameter sets.
With the 2018 release an included debugging
tool helps to check formal syntax.
Why use it?

More easily develop your build strategies
with faster debugging.
How to use it?

Examples for CLI and SLC are available to
accelerate adoption.

New machine workspaces
Netfabb Standard

New workspaces added:
Carbon M1 & M2
Sinterit Lisa
Prodways ProMaker P1000
Rapidshape (24 machines)

Multi-head printers added:
Titan Robotics Prometheus
Kloner 3D 240 Twin

Fused filament fabrication enhancements
Netfabb Standard

New workspaces added:
German RepRap

ZYYX pro & ZYYX+
What’s new:

Faster toolpath generation
Improved toolpath visualization
FFF optimized supports

Design for Additive
Manufacturing
Netfabb &
Optimization Utility for Netfabb

[Tech preview] Autodesk® Generative Design
Netfabb Ultimate

[Tech preview] Autodesk® Generative Design
Netfabb Ultimate

What is it?

Generative design technology takes goals set by a
designer or engineer, e.g. size, weight, strength, style,
materials, cost, and any number of other criteria, and
then uses cloud computing to create a massive
number of design solutions.
Why use it?

Explore a wide variety of valid, functional, and
manufacturable designs to help reduce cost,
development time, material consumption, and weight.
How to use it?

Netfabb Ultimate subscribers will be contacted
directly with more information on how to access and
use the technology when it becomes available later
this summer.
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[Tech preview] Lattice commander
Netfabb Ultimate

What is it?

Simplified approach to generating lattice structures
and skins within the core Netfabb interface. This new
feature includes:
Preview for lattice topologies
Generation of lattice & skin meshes
Modify lattices & skins using standard Netfabb
mesh toolset
Why use it?

Create high-value designs optimized for additive
manufacturing directly from the standard Netfabb
application.
How to use it?

Enable tech preview from Help->Preview Opt-In
Open Lattice Commander from Modify menu.

New results for topology optimization
Netfabb Ultimate

What is it?

See results in 2D view graphs and
display intermediate results for
topology optimization.
Why use it?

View extended results for each iteration
of the optimization process.
How to use it?

View intermediate results as
optimization is in process.

Minimize the Risk &
Cost of Build Failures
Simulation Utility for Netfabb

View simulation results for support placement
Netfabb Premium + Netfabb Simulation Solver

What is it?

Setup and run Netfabb Simulation from the
Netfabb & PowerShape Utility environments and
view results while placing or editing supports.
Why use it?

Reduce the likelihood of support failure by
making informed decisions when placing and
sizing support structures.
How to use it?

Open results file using ‘View Netfabb Simulation
Results’ in the the Analyze menu.
Choose the time step & result type to load, then
click ‘Display for support editing’.

Export compensated shape
Netfabb Premium + Netfabb Simulation Solver

What is it?

Export the compensated shape from Netfabb
Simulation as an STL file.
Why use it?

Use compensated shape to counteract distortion
and achieve the desired shape when printed.

STL file

Auto-generated mesh

Compensated STL file

Distortion results

How to use it?

Select ‘Warped STL’ from ribbon toolbar to
export compensated shape.

Display stress results
Netfabb Premium + Netfabb Simulation Solver

What is it?

Output stress results from solver for postprocessing. Available results include:
Cauchy
von Mises
Principal stresses
Why use it?

View stresses to identify potential cracking
issues or support structure failures.
How to use it?

View results from list in project tree.

Qualitative & quantitative stress results
Netfabb Premium + Netfabb Simulation Solver

What is it?

Choose between Quantitative or Qualitative
stress calculations.
Why use it?

Qualitative results provide insight into part
distortion or failure during the build process.

Quantitative results provide information
regarding post-process stresses and possible
distortion after build plate removal.
How to use it?

Choose the type of stress calculation from the
Results tab in the Analysis settings dialog.

Multiple STL file import
Netfabb Premium + Netfabb Simulation Solver

What is it?

Import multiple parts and support structures into
the simulation project.
Support volume fraction specified on import
Use the move command to orient parts on
platform
Why use it?

Simulate the entire build platform to get more
accurate results of the real-world process.
How to use it?

Use the ‘Import’ command to bring in multiple STL
files. Use the ‘Move’ command to orient objects on
the platform.

Interoperability with Netfabb
Netfabb Premium + Netfabb Simulation Solver

What is it?

Import the machine manufacturer and
model info, built plate size, and number of
lasers from Netfabb into Simulation Utility.
Why use it?

Speed up analysis preparation time.
How to use it?

Select ‘Simulate Build Process’ in the
Analyze menu.

Account for trapped powder
Netfabb Premium + Netfabb Simulation Solver
Uniform heat flux

What is it?

Option to mesh and simulate loose powder between
parts and/or support structures.
Why use it?

Increase thermal analysis accuracy to account for
conduction to trapped powder when parts are closely
nested on the build platform.
How to use it?

Select ‘Trapped Powder’ from Analysis Settings
dialog.

Conduction to loose powder

Improved part interaction
Netfabb Premium + Netfabb Simulation Solver

What is it?

Suppress or remove unwanted geometry from the
simulation and easier selection of geometry for
move command upon placement.
Why use it?

More control over geometry availability and
placement speeds up the preparation process.
How to use it?

Right click on parts in the model tree, select
‘Suppress’, ‘Remove’, or ‘Move’.

Additional meshing controls
Netfabb Premium + Netfabb Simulation Solver
Wall thickness

What is it?

Ability to choose between wall thickness or layer
based meshing approaches and specify mesh sizing
parameters.
Why use it?

Improved control over meshing helps balance
analysis time and accuracy.
How to use it?

In the Analysis Setup dialog, use the Mesh tab to
specify meshing parameters.

Layer based

Assign unique PRM file for each geometry
Netfabb Premium + Netfabb Simulation Solver

What is it?

Apply unique processing parameters for
each geometry in the analysis.
Why use it?

Accurately reflect differences in realworld processing parameters between
support structures and parts.
How to use it?

Select ‘Per geometry’ within the Analysis
settings dialog and specify the
appropriate PRM file for each item from
the model tree.

Stop analysis if recoater interference detected
Netfabb Premium + Netfabb Simulation Solver

What is it?

Option to stop the analysis if recoater interference is
detected.
Why use it?

Eliminate wasted processing time calculating the
build after a recoater interference is detected.
How to use it?

Check ‘Stop analysis if recoater interference is
detected’ from the Analysis tab in the Analysis
settings dialog.

Create custom materials
Netfabb Premium + Netfabb Simulation Solver

What is it?

New dialog to specify custom material properties &
ability to monitor and cancel PRM generation via the
job manager.
Why use it?

Simulate materials not currently available in library
or use your own measured properties.
How to use it?

Open material library from the Home tab and enter in
custom material data.

*Minimum requirements must be met for material to be applied to build plate or
for PRM generation.

UX refinements
Netfabb Premium + Netfabb Simulation Solver

What is it?

Pre-processor enhancements include:
Define the background color
Enhanced move command

Post-processor enhancements include:
New dialog for clipping plane

Why use it?

Easier to setup analyses and interrogate results.
How to use it?

Background color and clipping planes are available in
the ‘View’ tab.

Material database updates
Netfabb Premium + Netfabb Simulation Solver

Material database additions:

Cobalt Chrome
Inconel 718 plus
Materials updated with as-deposited properties*:

Inconel 625

Inconel 718

*Simulations performed with Inconel 625 and Inconel 718 may produce different results than previous versions.

Efficient Preparation for
CNC Finishing
Powershape Utility for Netfabb

Dynamic editing for Flexistock and Superstructure
Netfabb Premium

What is it?

Dynamically change the size, orientation, and
placement of Flexistock and Superstructures.
Why use it?

More precise control when adding stock to the part or
placing support structures.
How to use it?

Upon placement of Flexistock or Superstructures, use
your cursor to dynamically change the geometry.

Export for simulation
Netfabb Premium

What is it?

Automatically send parts and supports/fixtures to the
Netfabb Simulation Utility.
Why use it?

Quickly export multiple geometries for analysis.
How to use it?

‘Simulate parts and fixtures’ command is available in
the tree or column fixture menus.

Autodesk, Netfabb, and the Autodesk logo are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and/or other countries. All other brand names, product names, or trademarks belong to
their respective holders. Autodesk reserves the right to alter product and services offerings, and specifications and pricing at any time without notice, and is not responsible for typographical or graphical errors that may appear in this
document.

© 2017 Autodesk. All rights reserved.

